tpm2-totp.mk 822 B

12345678910111213141516171819202122232425
  1. ################################################################################
  2. #
  3. # tpm2-totp
  4. #
  5. ################################################################################
  6. TPM2_TOTP_VERSION = 0.2.1
  7. TPM2_TOTP_SITE = https://github.com/tpm2-software/tpm2-totp/releases/download/v$(TPM2_TOTP_VERSION)
  8. TPM2_TOTP_LICENSE = BSD-3-Clause
  9. TPM2_TOTP_LICENSE_FILES = LICENSE
  10. TPM2_TOTP_DEPENDENCIES = libqrencode tpm2-tss host-pkgconf
  11. TPM2_TOTP_CONF_OPTS = \
  12. --disable-defaultflags \
  13. --disable-doxygen-doc \
  14. --disable-plymouth \
  15. --without-initramfstoolsdir \
  16. --without-mkinitcpiodir
  17. # uses C99 code but forgets to pass -std=c99 when --disable-defaultflags is used
  18. TPM2_TOTP_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
  19. # do not build man pages
  20. TPM2_TOTP_CONF_ENV += ac_cv_path_PANDOC=''
  21. $(eval $(autotools-package))