tiff.mk 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. ################################################################################
  2. #
  3. # tiff
  4. #
  5. ################################################################################
  6. TIFF_VERSION = 4.1.0
  7. TIFF_SITE = http://download.osgeo.org/libtiff
  8. TIFF_LICENSE = tiff license
  9. TIFF_LICENSE_FILES = COPYRIGHT
  10. TIFF_INSTALL_STAGING = YES
  11. TIFF_CONF_OPTS = \
  12. --disable-cxx \
  13. --without-x
  14. TIFF_DEPENDENCIES = host-pkgconf
  15. HOST_TIFF_CONF_OPTS = \
  16. --disable-cxx \
  17. --without-x \
  18. --disable-zlib \
  19. --disable-lzma \
  20. --disable-jpeg
  21. HOST_TIFF_DEPENDENCIES = host-pkgconf
  22. ifneq ($(BR2_PACKAGE_TIFF_CCITT),y)
  23. TIFF_CONF_OPTS += --disable-ccitt
  24. endif
  25. ifneq ($(BR2_PACKAGE_TIFF_PACKBITS),y)
  26. TIFF_CONF_OPTS += --disable-packbits
  27. endif
  28. ifneq ($(BR2_PACKAGE_TIFF_LZW),y)
  29. TIFF_CONF_OPTS += --disable-lzw
  30. endif
  31. ifneq ($(BR2_PACKAGE_TIFF_THUNDER),y)
  32. TIFF_CONF_OPTS += --disable-thunder
  33. endif
  34. ifneq ($(BR2_PACKAGE_TIFF_NEXT),y)
  35. TIFF_CONF_OPTS += --disable-next
  36. endif
  37. ifneq ($(BR2_PACKAGE_TIFF_LOGLUV),y)
  38. TIFF_CONF_OPTS += --disable-logluv
  39. endif
  40. ifneq ($(BR2_PACKAGE_TIFF_MDI),y)
  41. TIFF_CONF_OPTS += --disable-mdi
  42. endif
  43. ifneq ($(BR2_PACKAGE_TIFF_ZLIB),y)
  44. TIFF_CONF_OPTS += --disable-zlib
  45. else
  46. TIFF_DEPENDENCIES += zlib
  47. endif
  48. ifneq ($(BR2_PACKAGE_TIFF_XZ),y)
  49. TIFF_CONF_OPTS += --disable-lzma
  50. else
  51. TIFF_DEPENDENCIES += xz
  52. endif
  53. ifneq ($(BR2_PACKAGE_TIFF_PIXARLOG),y)
  54. TIFF_CONF_OPTS += --disable-pixarlog
  55. endif
  56. ifneq ($(BR2_PACKAGE_TIFF_JPEG),y)
  57. TIFF_CONF_OPTS += --disable-jpeg
  58. else
  59. TIFF_DEPENDENCIES += jpeg
  60. endif
  61. ifneq ($(BR2_PACKAGE_TIFF_OLD_JPEG),y)
  62. TIFF_CONF_OPTS += --disable-old-jpeg
  63. endif
  64. ifneq ($(BR2_PACKAGE_TIFF_JBIG),y)
  65. TIFF_CONF_OPTS += --disable-jbig
  66. endif
  67. TIFF_SUBDIRS = port libtiff
  68. ifeq ($(BR2_PACKAGE_TIFF_UTILITIES),y)
  69. TIFF_SUBDIRS += tools
  70. endif
  71. TIFF_MAKE = $(MAKE) SUBDIRS="$(TIFF_SUBDIRS)"
  72. $(eval $(autotools-package))
  73. $(eval $(host-autotools-package))