ti-cgt-pru.mk 1.4 KB

123456789101112131415161718192021222324252627282930313233
  1. ################################################################################
  2. #
  3. # ti-cgt-pru
  4. #
  5. ################################################################################
  6. TI_CGT_PRU_VERSION = 2.3.3
  7. TI_CGT_PRU_SOURCE = ti_cgt_pru_$(TI_CGT_PRU_VERSION)_linux_installer_x86.bin
  8. TI_CGT_PRU_SITE = http://downloads.ti.com/codegen/esd/cgt_public_sw/PRU/$(TI_CGT_PRU_VERSION)
  9. TI_CGT_PRU_LICENSE = TI Technology and Software Publicly Available License (compiler + PRU library), \
  10. BSL-1.0 (compiler), BSD-2-Clause, BSD-3-Clause, MIT, AFL-3.0, Hewlett-Packard (PRU library)
  11. TI_CGT_PRU_LICENSE_FILES = PRU_Code_Generation_Tools_2.3.x_manifest.html \
  12. pru_rts_2_3_0_82167478-F8C9-49b2-82BD-12F8550770F9.spdx
  13. define HOST_TI_CGT_PRU_EXTRACT_CMDS
  14. chmod +x $(HOST_TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE)
  15. $(HOST_TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE) --prefix $(@D) --mode unattended
  16. mv $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/* $(@D)
  17. rmdir $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/
  18. endef
  19. # Since this is largely prebuilt toolchain and likes to live in its
  20. # own directory, put it in $(HOST_DIR)/share/ti-cgt-pru/.
  21. # Packages wanting to use this toolchain need to use this path as TI's
  22. # standard PRU_CGT path e.g. make PRU_CGT=$(TI_CGT_PRU_INSTALLDIR)...
  23. TI_CGT_PRU_INSTALLDIR = $(HOST_DIR)/share/ti-cgt-pru
  24. define HOST_TI_CGT_PRU_INSTALL_CMDS
  25. mkdir -p $(TI_CGT_PRU_INSTALLDIR)
  26. cp -dpfr $(@D)/* $(TI_CGT_PRU_INSTALLDIR)
  27. endef
  28. $(eval $(host-generic-package))