tcpreplay.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. ################################################################################
  2. #
  3. # tcpreplay
  4. #
  5. ################################################################################
  6. TCPREPLAY_VERSION = 4.3.3
  7. TCPREPLAY_SITE = https://github.com/appneta/tcpreplay/releases/download/v$(TCPREPLAY_VERSION)
  8. TCPREPLAY_SOURCE = tcpreplay-$(TCPREPLAY_VERSION).tar.xz
  9. TCPREPLAY_LICENSE = GPL-3.0
  10. TCPREPLAY_LICENSE_FILES = docs/LICENSE
  11. TCPREPLAY_CONF_ENV = \
  12. ac_cv_path_ac_pt_PCAP_CONFIG="$(STAGING_DIR)/usr/bin/pcap-config"
  13. TCPREPLAY_CONF_OPTS = --with-libpcap=$(STAGING_DIR)/usr \
  14. --enable-pcapconfig
  15. TCPREPLAY_DEPENDENCIES = libpcap
  16. # We're patching configure.ac
  17. TCPREPLAY_AUTORECONF = YES
  18. ifeq ($(BR2_STATIC_LIBS),y)
  19. TCPREPLAY_CONF_OPTS += --enable-dynamic-link=no
  20. TCPREPLAY_CONF_ENV += LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --libs`"
  21. endif
  22. ifeq ($(BR2_PACKAGE_LIBDNET),y)
  23. TCPREPLAY_DEPENDENCIES += libdnet
  24. TCPREPLAY_CONF_OPTS += --with-libdnet=$(STAGING_DIR)/usr
  25. else
  26. TCPREPLAY_CONF_OPTS += --without-libdnet
  27. endif
  28. ifeq ($(BR2_PACKAGE_TCPDUMP),y)
  29. TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=/usr/sbin/tcpdump
  30. else
  31. TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=no
  32. endif
  33. $(eval $(autotools-package))