tcf-agent.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # tcf-agent
  4. #
  5. ################################################################################
  6. TCF_AGENT_VERSION = 1.7.0
  7. # the tar.xz link was broken the time this file got authored
  8. TCF_AGENT_SOURCE = org.eclipse.tcf.agent-$(TCF_AGENT_VERSION).tar.gz
  9. TCF_AGENT_SITE = http://git.eclipse.org/c/tcf/org.eclipse.tcf.agent.git/snapshot
  10. # see https://wiki.spdx.org/view/Legal_Team/License_List/Licenses_Under_Consideration
  11. TCF_AGENT_LICENSE = BSD-3-Clause
  12. TCF_AGENT_LICENSE_FILES = agent/edl-v10.html
  13. TCF_AGENT_DEPENDENCIES = util-linux
  14. TCF_AGENT_SUBDIR = agent
  15. # there is not much purpose for the shared lib,
  16. # if wont be used (unmodifed) outside the tcf-agent application
  17. TCF_AGENT_CONF_OPTS = \
  18. -DBUILD_SHARED_LIBS=OFF \
  19. -DTCF_MACHINE=$(call qstrip,$(BR2_PACKAGE_TCF_AGENT_ARCH))
  20. define TCF_AGENT_INSTALL_INIT_SYSTEMD
  21. $(INSTALL) -D -m 644 package/tcf-agent/tcf-agent.service \
  22. $(TARGET_DIR)/usr/lib/systemd/system/tcf-agent.service
  23. endef
  24. define TCF_AGENT_INSTALL_INIT_SYSV
  25. $(INSTALL) -D -m 755 package/tcf-agent/S55tcf-agent \
  26. $(TARGET_DIR)/etc/init.d/S55tcf-agent
  27. endef
  28. $(eval $(cmake-package))