sysdig.mk 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. ################################################################################
  2. #
  3. # sysdig
  4. #
  5. ################################################################################
  6. SYSDIG_VERSION = 0.23.1
  7. SYSDIG_SITE = $(call github,draios,sysdig,$(SYSDIG_VERSION))
  8. SYSDIG_LICENSE = GPL-2.0
  9. SYSDIG_LICENSE_FILES = COPYING
  10. SYSDIG_CONF_OPTS = -DENABLE_DKMS=OFF -DUSE_BUNDLED_DEPS=OFF
  11. SYSDIG_SUPPORTS_IN_SOURCE_BUILD = NO
  12. SYSDIG_DEPENDENCIES = \
  13. elfutils \
  14. jq \
  15. jsoncpp \
  16. libb64 \
  17. libcurl \
  18. luainterpreter \
  19. ncurses \
  20. openssl \
  21. zlib
  22. # sysdig creates the module Makefile from a template, which contains a
  23. # single place-holder, KBUILD_FLAGS, wich is only replaced with two
  24. # things:
  25. # - debug flags, which we don't care about here,
  26. # - 'sysdig-feature' flags, which are never set, so always empty
  27. # So, just replace the place-holder with the only meaningful value: nothing.
  28. define SYSDIG_MODULE_GEN_MAKEFILE
  29. $(INSTALL) -m 0644 $(@D)/driver/Makefile.in $(@D)/driver/Makefile
  30. $(SED) 's/@KBUILD_FLAGS@//;' $(@D)/driver/Makefile
  31. $(SED) 's/@PROBE_NAME@/sysdig-probe/;' $(@D)/driver/Makefile
  32. endef
  33. SYSDIG_POST_PATCH_HOOKS += SYSDIG_MODULE_GEN_MAKEFILE
  34. # Don't build the driver as part of the 'standard' procedure, we'll
  35. # build it on our own with the kernel-module infra.
  36. SYSDIG_CONF_OPTS += -DBUILD_DRIVER=OFF
  37. SYSDIG_MODULE_SUBDIRS = driver
  38. SYSDIG_MODULE_MAKE_OPTS = KERNELDIR=$(LINUX_DIR)
  39. $(eval $(kernel-module))
  40. $(eval $(cmake-package))