sylpheed.mk 1.0 KB

123456789101112131415161718192021222324252627282930313233
  1. ################################################################################
  2. #
  3. # sylpheed
  4. #
  5. ################################################################################
  6. SYLPHEED_VERSION_MAJOR = 3.7
  7. SYLPHEED_VERSION = $(SYLPHEED_VERSION_MAJOR).0
  8. SYLPHEED_SOURCE = sylpheed-$(SYLPHEED_VERSION).tar.xz
  9. SYLPHEED_SITE = http://sylpheed.sraoss.jp/sylpheed/v$(SYLPHEED_VERSION_MAJOR)
  10. SYLPHEED_LICENSE = GPL-2.0+ (executables), LGPL-2.1+ (library, attachment plugin)
  11. SYLPHEED_LICENSE_FILES = COPYING COPYING.LIB
  12. SYLPHEED_CONF_OPTS = --disable-gtkspell --disable-gpgme
  13. SYLPHEED_DEPENDENCIES = host-pkgconf libgtk2
  14. # Remove the -I$(includedir) from the Makefiles
  15. # because it refers to the host /usr/include.
  16. define SYLPHEED_PRECONFIGURE
  17. for i in $$(find $(@D) -name "Makefile*"); do \
  18. sed -i 's:-I$$(includedir)::g' $$i; \
  19. done
  20. endef
  21. SYLPHEED_PRE_CONFIGURE_HOOKS += SYLPHEED_PRECONFIGURE
  22. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  23. SYLPHEED_DEPENDENCIES += openssl
  24. SYLPHEED_CONF_OPTS += --enable-ssl
  25. else
  26. SYLPHEED_CONF_OPTS += --disable-ssl
  27. endif
  28. $(eval $(autotools-package))