supervisor.mk 1.1 KB

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # supervisor
  4. #
  5. ################################################################################
  6. SUPERVISOR_VERSION = 4.1.0
  7. SUPERVISOR_SITE = https://files.pythonhosted.org/packages/de/87/ee1ad8fa533a4b5f2c7623f4a2b585d3c1947af7bed8e65bc7772274320e
  8. SUPERVISOR_LICENSE = BSD-like, rdflib (http_client.py), PSF (medusa)
  9. SUPERVISOR_LICENSE_FILES = COPYRIGHT.txt LICENSES.txt
  10. SUPERVISOR_SETUP_TYPE = setuptools
  11. define SUPERVISOR_INSTALL_CONF_FILES
  12. $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
  13. $(INSTALL) -D -m 644 package/supervisor/supervisord.conf \
  14. $(TARGET_DIR)/etc/supervisord.conf
  15. endef
  16. SUPERVISOR_POST_INSTALL_TARGET_HOOKS += SUPERVISOR_INSTALL_CONF_FILES
  17. define SUPERVISOR_INSTALL_INIT_SYSV
  18. $(INSTALL) -D -m 755 package/supervisor/S99supervisord \
  19. $(TARGET_DIR)/etc/init.d/S99supervisord
  20. endef
  21. define SUPERVISOR_INSTALL_INIT_SYSTEMD
  22. $(INSTALL) -D -m 644 package/supervisor/supervisord.service \
  23. $(TARGET_DIR)/usr/lib/systemd/system/supervisord.service
  24. endef
  25. $(eval $(python-package))