supertuxkart.mk 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. ################################################################################
  2. #
  3. # supertuxkart
  4. #
  5. ################################################################################
  6. SUPERTUXKART_VERSION = 1.1
  7. SUPERTUXKART_SOURCE = supertuxkart-$(SUPERTUXKART_VERSION)-src.tar.xz
  8. SUPERTUXKART_SITE = http://downloads.sourceforge.net/project/supertuxkart/SuperTuxKart/$(SUPERTUXKART_VERSION)
  9. # Supertuxkart itself is GPL-3.0+, but it bundles a few libraries with different
  10. # licenses. Irrlicht, bullet and angelscript have Zlib license, while glew is
  11. # BSD-3-Clause. Since they are linked statically, the result is GPL-3.0+.
  12. SUPERTUXKART_LICENSE = GPL-3.0+
  13. SUPERTUXKART_LICENSE_FILES = COPYING
  14. SUPERTUXKART_DEPENDENCIES = \
  15. host-pkgconf \
  16. freetype \
  17. enet \
  18. harfbuzz \
  19. jpeg \
  20. libcurl \
  21. libfribidi \
  22. libgl \
  23. libglew \
  24. libogg \
  25. libpng \
  26. libsquish \
  27. libvorbis \
  28. openal \
  29. xlib_libXrandr \
  30. zlib
  31. # Since supertuxkart is not installing libstkirrlicht.so, and since it is
  32. # the only user of the bundled libraries, turn off shared libraries entirely.
  33. # Disable In-game recorder (there is no libopenglrecorder package)
  34. SUPERTUXKART_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF \
  35. -DBUILD_RECORDER=OFF \
  36. -DUSE_SYSTEM_GLEW=ON \
  37. -DUSE_SYSTEM_ENET=ON \
  38. -DUSE_SYSTEM_SQUISH=ON
  39. ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
  40. SUPERTUXKART_DEPENDENCIES += bluez5_utils
  41. SUPERTUXKART_CONF_OPTS += -DUSE_WIIUSE=ON -DUSE_SYSTEM_WIIUSE=ON
  42. else
  43. # Wiimote support relies on bluez5.
  44. SUPERTUXKART_CONF_OPTS += -DUSE_WIIUSE=OFF
  45. endif
  46. # Prefer openssl (the default) over nettle.
  47. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  48. SUPERTUXKART_DEPENDENCIES += openssl
  49. SUPERTUXKART_CONF_OPTS += -DUSE_CRYPTO_OPENSSL=ON
  50. else
  51. SUPERTUXKART_DEPENDENCIES += nettle
  52. SUPERTUXKART_CONF_OPTS += -DUSE_CRYPTO_OPENSSL=OFF
  53. endif
  54. ifeq ($(BR2_PACKAGE_SQLITE),y)
  55. SUPERTUXKART_DEPENDENCIES += sqlite
  56. SUPERTUXKART_CONF_OPTS += -DUSE_SQLITE3=ON
  57. else
  58. SUPERTUXKART_CONF_OPTS += -DUSE_SQLITE3=OFF
  59. endif
  60. $(eval $(cmake-package))