sunwait.mk 708 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # sunwait
  4. #
  5. ################################################################################
  6. SUNWAIT_VERSION = 7326b53e5406c7ebd552ae6dc0fc659252a18e7f
  7. SUNWAIT_SITE = $(call github,risacher,sunwait,$(SUNWAIT_VERSION))
  8. SUNWAIT_LICENSE = GPL-3.0
  9. SUNWAIT_LICENSE_FILES = LICENSE
  10. SUNWAIT_MAKE_OPTS = \
  11. $(TARGET_CONFIGURE_OPTS) \
  12. C=$(TARGET_CXX) \
  13. CFLAGS="$(TARGET_CFLAGS) -c" \
  14. LDFLAGS="$(TARGET_LDFLAGS) -lm"
  15. define SUNWAIT_BUILD_CMDS
  16. $(MAKE) $(SUNWAIT_MAKE_OPTS) -C $(@D) all
  17. endef
  18. define SUNWAIT_INSTALL_TARGET_CMDS
  19. $(INSTALL) -D -m 0755 $(@D)/sunwait $(TARGET_DIR)/usr/bin/sunwait
  20. endef
  21. $(eval $(generic-package))