stress.mk 814 B

12345678910111213141516171819202122232425
  1. ################################################################################
  2. #
  3. # stress
  4. #
  5. ################################################################################
  6. STRESS_VERSION = 1.0.4
  7. STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
  8. STRESS_LICENSE = GPL-2.0+
  9. STRESS_LICENSE_FILES = COPYING
  10. # Stress is linked statically if the --enable-static is specified.
  11. # However, this option is always specified in the global
  12. # SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries,
  13. # if supported.
  14. #
  15. # If the BR2_STATIC_LIBS is not defined, we have to specify
  16. # --disable-static explicitly to get stress linked dynamically.
  17. #
  18. # Also, disable documentation by undefining makeinfo
  19. STRESS_CONF_OPTS = \
  20. $(if $(BR2_STATIC_LIBS),,--disable-static) \
  21. MAKEINFO=:
  22. $(eval $(autotools-package))