stress-ng.mk 1.1 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # stress-ng
  4. #
  5. ################################################################################
  6. STRESS_NG_VERSION = 0.11.17
  7. STRESS_NG_SOURCE = stress-ng-$(STRESS_NG_VERSION).tar.xz
  8. STRESS_NG_SITE = http://kernel.ubuntu.com/~cking/tarballs/stress-ng
  9. STRESS_NG_LICENSE = GPL-2.0+
  10. STRESS_NG_LICENSE_FILES = COPYING
  11. ifeq ($(BR2_PACKAGE_LIBBSD):$(BR2_STATIC_LIBS),y:)
  12. STRESS_NG_DEPENDENCIES += libbsd
  13. else
  14. STRESS_NG_MAKE_OPTS += HAVE_LIB_BSD=0 HAVE_WCSLCAT=0 \
  15. HAVE_WCSLCPY=0 HAVE_SETPROCTITLE=0
  16. endif
  17. ifeq ($(BR2_PACKAGE_KEYUTILS),y)
  18. STRESS_NG_DEPENDENCIES += keyutils
  19. endif
  20. define STRESS_NG_BUILD_CMDS
  21. $(TARGET_CONFIGURE_OPTS) $(MAKE) $(STRESS_NG_MAKE_OPTS) -C $(@D)
  22. endef
  23. # Don't use make install otherwise stress-ng will be rebuild without
  24. # required link libraries if any. Furthermore, using INSTALL allow to
  25. # set the file permission correcly on the target.
  26. define STRESS_NG_INSTALL_TARGET_CMDS
  27. $(INSTALL) -m 0755 -D $(@D)/stress-ng $(TARGET_DIR)/usr/bin/stress-ng
  28. endef
  29. $(eval $(generic-package))