stella.mk 1004 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. ################################################################################
  2. #
  3. # stella
  4. #
  5. ################################################################################
  6. STELLA_VERSION = 6.3
  7. STELLA_SOURCE = stella-$(STELLA_VERSION)-src.tar.xz
  8. STELLA_SITE = https://github.com/stella-emu/stella/releases/download/$(STELLA_VERSION)
  9. STELLA_LICENSE = GPL-2.0+
  10. STELLA_LICENSE_FILES = Copyright.txt License.txt
  11. STELLA_DEPENDENCIES = sdl2 libpng zlib
  12. STELLA_CONF_OPTS = \
  13. --host=$(GNU_TARGET_NAME) \
  14. --prefix=/usr \
  15. --with-sdl-prefix=$(STAGING_DIR)/usr
  16. # The configure script is not autoconf based, so we use the
  17. # generic-package infrastructure
  18. define STELLA_CONFIGURE_CMDS
  19. (cd $(@D); \
  20. $(TARGET_CONFIGURE_OPTS) \
  21. $(TARGET_CONFIGURE_ARGS) \
  22. ./configure $(STELLA_CONF_OPTS) \
  23. )
  24. endef
  25. define STELLA_BUILD_CMDS
  26. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
  27. endef
  28. define STELLA_INSTALL_TARGET_CMDS
  29. $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
  30. endef
  31. $(eval $(generic-package))