sshguard.mk 1.0 KB

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # sshguard
  4. #
  5. ################################################################################
  6. SSHGUARD_VERSION = 2.4.1
  7. SSHGUARD_SITE = https://sourceforge.net/projects/sshguard/files/sshguard/$(SSHGUARD_VERSION)
  8. SSHGUARD_LICENSE = ISC, Public Domain (fnv hash), BSD-3-Clause (SimCList)
  9. SSHGUARD_LICENSE_FILES = COPYING
  10. define SSHGUARD_INSTALL_CONFIG
  11. $(INSTALL) -D -m 0644 $(@D)/examples/sshguard.conf.sample \
  12. $(TARGET_DIR)/etc/sshguard.conf
  13. $(SED) '/^#BACKEND/c\BACKEND="/usr/libexec/sshg-fw-iptables"' \
  14. -e '/^#FILES/c\FILES="/var/log/messages"' $(TARGET_DIR)/etc/sshguard.conf
  15. endef
  16. SSHGUARD_POST_INSTALL_TARGET_HOOKS += SSHGUARD_INSTALL_CONFIG
  17. define SSHGUARD_INSTALL_INIT_SYSV
  18. $(INSTALL) -D -m 755 package/sshguard/S49sshguard \
  19. $(TARGET_DIR)/etc/init.d/S49sshguard
  20. endef
  21. define SSHGUARD_INSTALL_INIT_SYSTEMD
  22. $(INSTALL) -D -m 0644 $(@D)/examples/sshguard.service \
  23. $(TARGET_DIR)/usr/lib/systemd/system/sshguard.service
  24. endef
  25. $(eval $(autotools-package))