snmppp.mk 749 B

123456789101112131415161718192021222324
  1. ################################################################################
  2. #
  3. # snmppp
  4. #
  5. ################################################################################
  6. SNMPPP_VERSION = 3.4.2
  7. SNMPPP_SOURCE = snmp++-$(SNMPPP_VERSION).tar.gz
  8. SNMPPP_SITE = http://www.agentpp.com/download
  9. SNMPPP_DEPENDENCIES = host-pkgconf
  10. SNMPPP_INSTALL_STAGING = YES
  11. SNMPPP_CONF_OPTS = $(if $(BR2_PACKAGE_SNMPPP_LOGGING),--enable-logging,--disable-logging)
  12. SNMPPP_LICENSE = SNMP++
  13. SNMPPP_LICENSE_FILES = src/v3.cpp
  14. ifeq ($(BR2_PACKAGE_SNMPPP_SNMPV3),y)
  15. SNMPPP_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
  16. SNMPPP_CONF_OPTS += --enable-snmpv3
  17. SNMPPP_DEPENDENCIES += openssl
  18. else
  19. SNMPPP_CONF_OPTS += --disable-snmpv3
  20. endif
  21. $(eval $(autotools-package))