skeleton.mk 902 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # skeleton
  4. #
  5. ################################################################################
  6. # The skeleton can't depend on the toolchain, since all packages depends on the
  7. # skeleton and the toolchain is a target package, as is skeleton.
  8. # Hence, skeleton would depends on the toolchain and the toolchain would depend
  9. # on skeleton.
  10. SKELETON_ADD_TOOLCHAIN_DEPENDENCY = NO
  11. SKELETON_ADD_SKELETON_DEPENDENCY = NO
  12. # We create a compatibility symlink in case a post-build script still
  13. # uses $(HOST_DIR)/usr
  14. define HOST_SKELETON_INSTALL_CMDS
  15. $(Q)ln -snf . $(HOST_DIR)/usr
  16. $(Q)mkdir -p $(HOST_DIR)/lib
  17. $(Q)mkdir -p $(HOST_DIR)/include
  18. $(Q)case $(HOSTARCH) in \
  19. (*64) ln -snf lib $(HOST_DIR)/lib64;; \
  20. (*) ln -snf lib $(HOST_DIR)/lib32;; \
  21. esac
  22. endef
  23. $(eval $(virtual-package))
  24. $(eval $(host-generic-package))