sdl_sound.mk 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. ################################################################################
  2. #
  3. # sdl_sound
  4. #
  5. ################################################################################
  6. SDL_SOUND_VERSION = 1.0.3
  7. SDL_SOUND_SOURCE = SDL_sound-$(SDL_SOUND_VERSION).tar.gz
  8. SDL_SOUND_SITE = http://icculus.org/SDL_sound/downloads
  9. SDL_SOUND_LICENSE = LGPL-2.1+
  10. SDL_SOUND_LICENSE_FILES = COPYING
  11. SDL_SOUND_INSTALL_STAGING = YES
  12. SDL_SOUND_DEPENDENCIES = sdl
  13. SDL_SOUND_CONF_OPTS = \
  14. --with-sdl-prefix=$(STAGING_DIR)/usr \
  15. --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
  16. --disable-sdltest \
  17. --enable-static
  18. ifneq ($(BR2_ENABLE_LOCALE),y)
  19. SDL_SOUND_DEPENDENCIES += libiconv
  20. endif
  21. # optional dependencies
  22. ifeq ($(BR2_PACKAGE_FLAC)$(BR2_PACKAGE_LIBOGG),yy)
  23. SDL_SOUND_CONF_OPTS += --enable-flac
  24. SDL_SOUND_DEPENDENCIES += flac libogg
  25. else
  26. SDL_SOUND_CONF_OPTS += --disable-flac
  27. endif
  28. ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
  29. SDL_SOUND_CONF_OPTS += --enable-modplug
  30. SDL_SOUND_DEPENDENCIES += libmodplug
  31. else
  32. SDL_SOUND_CONF_OPTS += --disable-modplug
  33. endif
  34. ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
  35. SDL_SOUND_CONF_OPTS += --enable-ogg
  36. SDL_SOUND_DEPENDENCIES += libvorbis
  37. else
  38. SDL_SOUND_CONF_OPTS += --disable-ogg
  39. endif
  40. ifeq ($(BR2_PACKAGE_SPEEX),y)
  41. SDL_SOUND_CONF_OPTS += --enable-speex
  42. SDL_SOUND_DEPENDENCIES += speex
  43. else
  44. SDL_SOUND_CONF_OPTS += --disable-speex
  45. endif
  46. ifeq ($(BR2_PACKAGE_PHYSFS),y)
  47. SDL_SOUND_CONF_OPTS += --enable-physfs
  48. SDL_SOUND_DEPENDENCIES += physfs
  49. else
  50. SDL_SOUND_CONF_OPTS += --disable-physfs
  51. endif
  52. ifeq ($(BR2_X86_CPU_HAS_MMX),y)
  53. SDL_SOUND_CONF_OPTS += --enable-mmx
  54. else
  55. SDL_SOUND_CONF_OPTS += --disable-mmx
  56. endif
  57. define SDL_SOUND_REMOVE_PLAYSOUND
  58. rm $(addprefix $(TARGET_DIR)/usr/bin/,playsound playsound_simple)
  59. endef
  60. ifneq ($(BR2_PACKAGE_SDL_SOUND_PLAYSOUND),y)
  61. SDL_SOUND_POST_INSTALL_TARGET_HOOKS += SDL_SOUND_REMOVE_PLAYSOUND
  62. endif
  63. $(eval $(autotools-package))