sdl_gfx.mk 896 B

12345678910111213141516171819202122232425262728
  1. ################################################################################
  2. #
  3. # sdl_gfx
  4. #
  5. ################################################################################
  6. SDL_GFX_VERSION_MAJOR = 2.0
  7. SDL_GFX_VERSION = $(SDL_GFX_VERSION_MAJOR).23
  8. SDL_GFX_SOURCE = SDL_gfx-$(SDL_GFX_VERSION).tar.gz
  9. SDL_GFX_SITE = http://www.ferzkopp.net/Software/SDL_gfx-$(SDL_GFX_VERSION_MAJOR)
  10. SDL_GFX_LICENSE = Zlib
  11. SDL_GFX_LICENSE_FILES = COPYING LICENSE
  12. SDL_GFX_INSTALL_STAGING = YES
  13. SDL_GFX_DEPENDENCIES = sdl
  14. SDL_GFX_CONF_OPTS = \
  15. --with-sdl-prefix=$(STAGING_DIR)/usr \
  16. --disable-sdltest \
  17. --enable-static
  18. # Even though x86_64 processors support MMX, the MMX-specific assembly
  19. # code in sdl_gfx is IA32 specific, and does not build for x86_64.
  20. ifeq ($(BR2_i386)$(BR2_X86_CPU_HAS_MMX),yy)
  21. SDL_GFX_CONF_OPTS += --enable-mmx
  22. else
  23. SDL_GFX_CONF_OPTS += --disable-mmx
  24. endif
  25. $(eval $(autotools-package))