sdl2_ttf.mk 926 B

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # sdl2_ttf
  4. #
  5. ################################################################################
  6. SDL2_TTF_VERSION = 2.0.15
  7. SDL2_TTF_SOURCE = SDL2_ttf-$(SDL2_TTF_VERSION).tar.gz
  8. SDL2_TTF_SITE = http://www.libsdl.org/projects/SDL_ttf/release
  9. SDL2_TTF_LICENSE = Zlib
  10. SDL2_TTF_LICENSE_FILES = COPYING.txt
  11. SDL2_TTF_INSTALL_STAGING = YES
  12. SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
  13. SDL2_TTF_CONF_ENV = \
  14. FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
  15. # x-includes and x-libraries must be set for cross-compiling
  16. # By default x_includes and x_libraries contains unsafe paths.
  17. # (/usr/include and /usr/lib)
  18. ifeq ($(BR2_PACKAGE_SDL2_X11),y)
  19. SDL2_TTF_CONF_OPTS += \
  20. --with-x \
  21. --x-includes=$(STAGING_DIR)/usr/include \
  22. --x-libraries=$(STAGING_DIR)/usr/lib
  23. else
  24. SDL2_TTF_CONF_OPTS += \
  25. --without-x
  26. endif
  27. $(eval $(autotools-package))