sdl2_mixer.mk 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ################################################################################
  2. #
  3. # sdl2_mixer
  4. #
  5. ################################################################################
  6. SDL2_MIXER_VERSION = 2.0.4
  7. SDL2_MIXER_SOURCE = SDL2_mixer-$(SDL2_MIXER_VERSION).tar.gz
  8. SDL2_MIXER_SITE = http://www.libsdl.org/projects/SDL_mixer/release
  9. SDL2_MIXER_LICENSE = Zlib
  10. SDL2_MIXER_LICENSE_FILES = COPYING.txt
  11. SDL2_MIXER_INSTALL_STAGING = YES
  12. SDL2_MIXER_DEPENDENCIES = sdl2 host-pkgconf
  13. SDL2_MIXER_CONF_OPTS = --disable-music-mp3
  14. ifeq ($(BR2_PACKAGE_FLAC),y)
  15. SDL2_MIXER_CONF_OPTS += --enable-music-flac
  16. SDL2_MIXER_DEPENDENCIES += flac
  17. else
  18. SDL2_MIXER_CONF_OPTS += --disable-music-flac
  19. endif
  20. ifeq ($(BR2_PACKAGE_FLUIDSYNTH),y)
  21. SDL2_MIXER_CONF_OPTS += --enable-music-midi-fluidsynth
  22. SDL2_MIXER_DEPENDENCIES += fluidsynth
  23. else
  24. SDL2_MIXER_CONF_OPTS += --disable-music-midi-fluidsynth
  25. endif
  26. ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
  27. SDL2_MIXER_CONF_OPTS += --enable-music-mod-modplug
  28. SDL2_MIXER_DEPENDENCIES += libmodplug
  29. else
  30. SDL2_MIXER_CONF_OPTS += --disable-music-mod-modplug
  31. endif
  32. ifeq ($(BR2_PACKAGE_OPUSFILE),y)
  33. SDL2_MIXER_CONF_OPTS += --enable-music-opus
  34. SDL2_MIXER_DEPENDENCIES += opusfile
  35. else
  36. SDL2_MIXER_CONF_OPTS += --disable-music-opus
  37. endif
  38. ifeq ($(BR2_PACKAGE_TREMOR),y)
  39. SDL2_MIXER_CONF_OPTS += --enable-music-ogg-tremor
  40. SDL2_MIXER_DEPENDENCIES += tremor
  41. else
  42. SDL2_MIXER_CONF_OPTS += --disable-music-ogg-tremor
  43. endif
  44. $(eval $(autotools-package))