sdl2_gfx.mk 930 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # sdl2_gfx
  4. #
  5. ################################################################################
  6. SDL2_GFX_VERSION = 1.0.4
  7. SDL2_GFX_SOURCE = SDL2_gfx-$(SDL2_GFX_VERSION).tar.gz
  8. SDL2_GFX_SITE = http://www.ferzkopp.net/Software/SDL2_gfx
  9. SDL2_GFX_LICENSE = Zlib
  10. SDL2_GFX_LICENSE_FILES = COPYING SDL2_framerate.h
  11. SDL2_GFX_INSTALL_STAGING = YES
  12. SDL2_GFX_DEPENDENCIES = sdl2 host-pkgconf
  13. SDL2_GFX_CONF_OPTS = --disable-sdltest
  14. # configure/Makefile.in not up-to-date, causing aclocal to be used at
  15. # build time if we don't autoreconf.
  16. SDL2_GFX_AUTORECONF = YES
  17. # Even though x86_64 processors support MMX, the MMX-specific assembly
  18. # code in sdl2_gfx is IA32 specific, and does not build for x86_64.
  19. ifeq ($(BR2_i386)$(BR2_X86_CPU_HAS_MMX),yy)
  20. SDL2_GFX_CONF_OPTS += --enable-mmx
  21. else
  22. SDL2_GFX_CONF_OPTS += --disable-mmx
  23. endif
  24. $(eval $(autotools-package))