sdbusplus.mk 1.3 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # sdbusplus
  4. #
  5. ################################################################################
  6. SDBUSPLUS_VERSION = 4212292bcf136d04b38ba5116aa568b0fa312798
  7. SDBUSPLUS_SITE = $(call github,openbmc,sdbusplus,$(SDBUSPLUS_VERSION))
  8. SDBUSPLUS_DEPENDENCIES = host-autoconf-archive host-pkgconf systemd
  9. HOST_SDBUSPLUS_DEPENDENCIES = \
  10. host-autoconf-archive \
  11. host-pkgconf \
  12. $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python) \
  13. host-python-inflection \
  14. host-python-mako \
  15. host-python-pyyaml
  16. SDBUSPLUS_CONF_OPTS = --disable-sdbuspp
  17. HOST_SDBUSPLUS_CONF_OPTS = --disable-libsdbusplus
  18. SDBUSPLUS_AUTORECONF = YES
  19. SDBUSPLUS_AUTORECONF_OPTS = --include=$(HOST_DIR)/share/autoconf-archive
  20. SDBUSPLUS_INSTALL_STAGING = YES
  21. SDBUSPLUS_LICENSE = Apache-2.0
  22. SDBUSPLUS_LICENSE_FILES = LICENSE
  23. # Autoreconf is missing the m4/ directory, which might actually be missing
  24. # iff it was the first argument, but unfortunately we are overriding the
  25. # first include directory above. Thus we need that hook here.
  26. define SDBUSPLUS_CREATE_M4
  27. mkdir -p $(@D)/m4
  28. endef
  29. SDBUSPLUS_POST_PATCH_HOOKS += SDBUSPLUS_CREATE_M4
  30. HOST_SDBUSPLUS_POST_PATCH_HOOKS += SDBUSPLUS_CREATE_M4
  31. $(eval $(autotools-package))
  32. $(eval $(host-autotools-package))