rtc-tools.mk 820 B

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # rtc-tools
  4. #
  5. ################################################################################
  6. RTC_TOOLS_VERSION = 33ef4aa1c92b0c92a351284d93d1ac5570de9cc7
  7. RTC_TOOLS_SITE = git://git.kernel.org/pub/scm/linux/kernel/git/abelloni/rtc-tools.git
  8. RTC_TOOLS_LICENSE = GPL-2.0
  9. RTC_TOOLS_LICENSE_FILES = COPYING
  10. RTC_TOOLS_BINARIES = rtc rtc-range
  11. ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
  12. RTC_TOOLS_BINARIES += rtc-sync
  13. endif
  14. define RTC_TOOLS_BUILD_CMDS
  15. $(foreach bin,$(RTC_TOOLS_BINARIES),\
  16. $(TARGET_CC) $(TARGET_CFLAGS) -o $(@D)/$(bin) $(@D)/$(bin).c
  17. )
  18. endef
  19. define RTC_TOOLS_INSTALL_TARGET_CMDS
  20. $(foreach bin,$(RTC_TOOLS_BINARIES),\
  21. $(INSTALL) -D -m 0755 $(@D)/$(bin) $(TARGET_DIR)/usr/bin/$(bin)
  22. )
  23. endef
  24. $(eval $(generic-package))