rsyslog.mk 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. ################################################################################
  2. #
  3. # rsyslog
  4. #
  5. ################################################################################
  6. RSYSLOG_VERSION = 8.2004.0
  7. RSYSLOG_SITE = http://rsyslog.com/files/download/rsyslog
  8. RSYSLOG_LICENSE = GPL-3.0, LGPL-3.0, Apache-2.0
  9. RSYSLOG_LICENSE_FILES = COPYING COPYING.LESSER COPYING.ASL20
  10. RSYSLOG_DEPENDENCIES = zlib libestr liblogging libfastjson host-pkgconf
  11. RSYSLOG_CONF_ENV = ac_cv_prog_cc_c99='-std=c99'
  12. RSYSLOG_PLUGINS = imdiag imfile impstats imptcp \
  13. mmanon mmaudit mmfields mmjsonparse mmpstrucdata mmsequence mmutf8fix \
  14. mail omprog omruleset omstdout omuxsock \
  15. pmaixforwardedfrom pmciscoios pmcisconames pmlastmsg pmsnare
  16. ifeq ($(BR2_PACKAGE_LIBRELP),y)
  17. RSYSLOG_DEPENDENCIES += librelp
  18. RSYSLOG_PLUGINS += relp
  19. endif
  20. RSYSLOG_CONF_OPTS = --disable-generate-man-pages \
  21. $(foreach x,$(call qstrip,$(RSYSLOG_PLUGINS)),--enable-$(x))
  22. # Disable items requiring libcurl
  23. RSYSLOG_CONF_OPTS += --disable-elasticsearch \
  24. --disable-clickhouse \
  25. --disable-omhttp \
  26. --disable-fmhttp \
  27. --disable-imdocker \
  28. --disable-omhttpfs \
  29. --disable-mmkubernetes
  30. ifeq ($(BR2_PACKAGE_GNUTLS),y)
  31. RSYSLOG_DEPENDENCIES += gnutls
  32. RSYSLOG_CONF_OPTS += --enable-gnutls
  33. else
  34. RSYSLOG_CONF_OPTS += --disable-gnutls
  35. endif
  36. ifeq ($(BR2_PACKAGE_LIBEE),y)
  37. RSYSLOG_DEPENDENCIES += libee
  38. endif
  39. ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
  40. RSYSLOG_DEPENDENCIES += libgcrypt
  41. RSYSLOG_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
  42. RSYSLOG_CONF_OPTS += --enable-libgcrypt
  43. else
  44. RSYSLOG_CONF_OPTS += --disable-libgcrypt
  45. endif
  46. ifeq ($(BR2_PACKAGE_MYSQL),y)
  47. RSYSLOG_DEPENDENCIES += mysql
  48. RSYSLOG_CONF_OPTS += --enable-mysql
  49. RSYSLOG_CONF_ENV += ac_cv_prog_MYSQL_CONFIG=$(STAGING_DIR)/usr/bin/mysql_config
  50. else
  51. RSYSLOG_CONF_OPTS += --disable-mysql
  52. endif
  53. ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
  54. RSYSLOG_DEPENDENCIES += postgresql
  55. RSYSLOG_CONF_OPTS += --enable-pgsql
  56. RSYSLOG_CONF_ENV += ac_cv_prog_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
  57. else
  58. RSYSLOG_CONF_OPTS += --disable-pgsql
  59. endif
  60. ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
  61. RSYSLOG_DEPENDENCIES += util-linux
  62. RSYSLOG_CONF_OPTS += --enable-uuid
  63. else
  64. RSYSLOG_CONF_OPTS += --disable-uuid
  65. endif
  66. ifeq ($(BR2_INIT_SYSTEMD),y)
  67. RSYSLOG_CONF_OPTS += \
  68. --enable-imjournal \
  69. --enable-omjournal \
  70. --with-systemdsystemunitdir=/usr/lib/systemd/system
  71. RSYSLOG_DEPENDENCIES += systemd
  72. else
  73. RSYSLOG_CONF_OPTS += \
  74. --disable-imjournal \
  75. --disable-omjournal
  76. endif
  77. define RSYSLOG_INSTALL_INIT_SYSV
  78. $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslogd \
  79. $(TARGET_DIR)/etc/init.d/S01rsyslogd
  80. endef
  81. define RSYSLOG_INSTALL_CONF
  82. $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
  83. $(TARGET_DIR)/etc/rsyslog.conf
  84. mkdir -p $(TARGET_DIR)/etc/rsyslog.d
  85. endef
  86. RSYSLOG_POST_INSTALL_TARGET_HOOKS += RSYSLOG_INSTALL_CONF
  87. $(eval $(autotools-package))