rsync.mk 542 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # rsync
  4. #
  5. ################################################################################
  6. RSYNC_VERSION = 3.1.3
  7. RSYNC_SITE = http://rsync.samba.org/ftp/rsync/src
  8. RSYNC_LICENSE = GPL-3.0+
  9. RSYNC_LICENSE_FILES = COPYING
  10. RSYNC_DEPENDENCIES = zlib popt
  11. RSYNC_CONF_OPTS = \
  12. --with-included-zlib=no \
  13. --with-included-popt=no
  14. ifeq ($(BR2_PACKAGE_ACL),y)
  15. RSYNC_DEPENDENCIES += acl
  16. else
  17. RSYNC_CONF_OPTS += --disable-acl-support
  18. endif
  19. $(eval $(autotools-package))