rrdtool.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. ################################################################################
  2. #
  3. # rrdtool
  4. #
  5. ################################################################################
  6. RRDTOOL_VERSION = 1.7.2
  7. RRDTOOL_SITE = http://oss.oetiker.ch/rrdtool/pub
  8. RRDTOOL_LICENSE = GPL-2.0+ with FLOSS license exceptions as explained in COPYRIGHT
  9. RRDTOOL_LICENSE_FILES = COPYRIGHT LICENSE
  10. RRDTOOL_DEPENDENCIES = host-pkgconf libglib2 $(TARGET_NLS_DEPENDENCIES)
  11. # autoreconf needed to avoid link failure due to missing -lintl,
  12. # gettextize needed as a consequence of autoreconf
  13. RRDTOOL_AUTORECONF = YES
  14. RRDTOOL_GETTEXTIZE = YES
  15. RRDTOOL_INSTALL_STAGING = YES
  16. RRDTOOL_CONF_OPTS = \
  17. --disable-examples \
  18. --disable-libdbi \
  19. --disable-librados \
  20. --disable-libwrap \
  21. --disable-lua \
  22. --disable-perl \
  23. --disable-python \
  24. --disable-ruby \
  25. --disable-tcl
  26. ifeq ($(BR2_PACKAGE_RRDTOOL_RRDGRAPH),y)
  27. RRDTOOL_DEPENDENCIES += cairo pango
  28. else
  29. RRDTOOL_CONF_OPTS += --disable-rrd_graph
  30. endif
  31. ifeq ($(BR2_PACKAGE_LIBXML2),y)
  32. RRDTOOL_DEPENDENCIES += libxml2
  33. else
  34. RRDTOOL_CONF_OPTS += --disable-rrd_restore
  35. endif
  36. $(eval $(autotools-package))