resiprocate.mk 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ################################################################################
  2. #
  3. # resiprocate
  4. #
  5. ################################################################################
  6. RESIPROCATE_VERSION = 1.12.0
  7. RESIPROCATE_SITE = https://www.resiprocate.org/files/pub/reSIProcate/releases
  8. # For complete details see https://www.resiprocate.org/License
  9. RESIPROCATE_LICENSE = VSL-1.0, BSD-3-Clause
  10. RESIPROCATE_LICENSE_FILES = COPYING
  11. RESIPROCATE_INSTALL_STAGING = YES
  12. # Utilize c-ares from buildroot instead built in ARES library
  13. # NOTE: resiprocate doesn't support --without-<feature> syntax as it will try
  14. # to build with package if specified
  15. RESIPROCATE_DEPENDENCIES = c-ares
  16. RESIPROCATE_CONF_OPTS = -with-c-ares \
  17. --with-sysroot="$(STAGING_DIR)"
  18. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  19. RESIPROCATE_DEPENDENCIES += openssl host-pkgconf
  20. RESIPROCATE_CONF_OPTS += --with-ssl
  21. # Configure.ac does not include '-lz' when statically linking against openssl
  22. RESIPROCATE_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
  23. endif
  24. ifeq ($(BR2_PACKAGE_POPT),y)
  25. RESIPROCATE_CONF_OPTS += --with-popt
  26. RESIPROCATE_DEPENDENCIES += popt
  27. endif
  28. ifeq ($(BR2_PACKAGE_RESIPROCATE_DTLS_SUPPORT),y)
  29. RESIPROCATE_CONF_OPTS += --with-dtls
  30. endif
  31. ifeq ($(BR2_PACKAGE_RESIPROCATE_REND),y)
  32. RESIPROCATE_CONF_OPTS += --with-rend
  33. RESIPROCATE_DEPENDENCIES += boost
  34. endif
  35. ifeq ($(BR2_PACKAGE_RESIPROCATE_APPS),y)
  36. RESIPROCATE_CONF_OPTS += --with-apps
  37. RESIPROCATE_DEPENDENCIES += pcre
  38. endif
  39. $(eval $(autotools-package))