reaver.mk 732 B

1234567891011121314151617181920212223
  1. ################################################################################
  2. #
  3. # reaver
  4. #
  5. ################################################################################
  6. # Older repos for this project will not cross-compile easily
  7. # while this one works right away
  8. REAVER_VERSION = 1.6.6
  9. REAVER_SITE = $(call github,t6x,reaver-wps-fork-t6x,v$(REAVER_VERSION))
  10. REAVER_LICENSE = GPL-2.0+
  11. REAVER_LICENSE_FILES = docs/LICENSE
  12. REAVER_SUBDIR = src
  13. REAVER_DEPENDENCIES = libpcap
  14. ifeq ($(BR2_STATIC_LIBS),y)
  15. REAVER_CONF_ENV += \
  16. LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`" \
  17. LDFLAGS="$(TARGET_LDFLAGS) `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`"
  18. endif
  19. $(eval $(autotools-package))