rauc.mk 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ################################################################################
  2. #
  3. # rauc
  4. #
  5. ################################################################################
  6. RAUC_VERSION = 1.5
  7. RAUC_SITE = https://github.com/rauc/rauc/releases/download/v$(RAUC_VERSION)
  8. RAUC_SOURCE = rauc-$(RAUC_VERSION).tar.xz
  9. RAUC_LICENSE = LGPL-2.1
  10. RAUC_LICENSE_FILES = COPYING
  11. RAUC_DEPENDENCIES = host-pkgconf openssl libglib2 dbus
  12. ifeq ($(BR2_PACKAGE_RAUC_NETWORK),y)
  13. RAUC_CONF_OPTS += --enable-network
  14. RAUC_DEPENDENCIES += libcurl
  15. else
  16. RAUC_CONF_OPTS += --disable-network
  17. endif
  18. ifeq ($(BR2_PACKAGE_RAUC_JSON),y)
  19. RAUC_CONF_OPTS += --enable-json
  20. RAUC_DEPENDENCIES += json-glib
  21. else
  22. RAUC_CONF_OPTS += --disable-json
  23. endif
  24. ifeq ($(BR2_PACKAGE_SYSTEMD),y)
  25. # configure uses pkg-config --variable=systemdsystemunitdir systemd
  26. RAUC_DEPENDENCIES += systemd
  27. endif
  28. define RAUC_INSTALL_INIT_SYSTEMD
  29. mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
  30. printf '[Install]\nWantedBy=multi-user.target\n' \
  31. >$(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d/buildroot-enable.conf
  32. endef
  33. HOST_RAUC_DEPENDENCIES = \
  34. host-pkgconf \
  35. host-openssl \
  36. host-libglib2 \
  37. host-squashfs \
  38. $(if $(BR2_PACKAGE_HOST_LIBP11),host-libp11)
  39. HOST_RAUC_CONF_OPTS += \
  40. --disable-network \
  41. --disable-json \
  42. --disable-service \
  43. --without-dbuspolicydir \
  44. --with-systemdunitdir=no
  45. $(eval $(autotools-package))
  46. $(eval $(host-autotools-package))