ranger.mk 890 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # ranger
  4. #
  5. ################################################################################
  6. RANGER_VERSION = 1.7.2
  7. RANGER_SITE = http://ranger.nongnu.org
  8. RANGER_SETUP_TYPE = distutils
  9. RANGER_LICENSE = GPL-3.0
  10. RANGER_LICENSE_FILES = AUTHORS
  11. # The ranger script request python to be called with -O (optimize generated
  12. # bytecode slightly; also PYTHONOPTIMIZE=x). This implicitly requires the python
  13. # source files to be present. Therefore, the -O flag is removed when only the .pyc
  14. # files are installed.
  15. define RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
  16. $(SED) 's%/usr/bin/python -O%/usr/bin/python%g' $(@D)/scripts/ranger
  17. endef
  18. ifeq ($(BR2_PACKAGE_PYTHON3_PYC_ONLY)$(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
  19. RANGER_POST_PATCH_HOOKS += RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
  20. endif
  21. $(eval $(python-package))