ramspeed.mk 661 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # ramspeed
  4. #
  5. ################################################################################
  6. RAMSPEED_VERSION = 2.6.0
  7. RAMSPEED_SITE = http://www.alasir.com/software/ramspeed
  8. RAMSPEED_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
  9. RAMSPEED_LICENSE = Alasir License
  10. RAMSPEED_LICENSE_FILES = LICENCE
  11. define RAMSPEED_BUILD_CMDS
  12. cp -f package/ramspeed/Makefile $(@D)
  13. $(TARGET_CONFIGURE_OPTS) make -C $(@D) $(RAMSPEED_ARCH)
  14. endef
  15. define RAMSPEED_INSTALL_TARGET_CMDS
  16. $(INSTALL) -m 0755 -D $(@D)/ramspeed $(TARGET_DIR)/usr/bin/ramspeed
  17. endef
  18. $(eval $(generic-package))