quota.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. ################################################################################
  2. #
  3. # quota
  4. #
  5. ################################################################################
  6. QUOTA_VERSION = 4.05
  7. QUOTA_SITE = http://downloads.sourceforge.net/project/linuxquota/quota-tools/$(QUOTA_VERSION)
  8. QUOTA_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) host-nfs-utils
  9. QUOTA_LICENSE = GPL-2.0+
  10. QUOTA_LICENSE_FILES = COPYING
  11. # We're patching configure.ac
  12. QUOTA_AUTORECONF = YES
  13. QUOTA_GETTEXTIZE = YES
  14. QUOTA_CONF_ENV = LIBS="$(TARGET_NLS_LIBS)"
  15. QUOTA_CONF_OPTS = --disable-pie
  16. ifeq ($(BR2_PACKAGE_DBUS)$(BR2_PACKAGE_LIBNL),yy)
  17. QUOTA_DEPENDENCIES += host-pkgconf dbus libnl
  18. QUOTA_CONF_OPTS += --enable-netlink
  19. else
  20. QUOTA_CONF_OPTS += --disable-netlink
  21. endif
  22. ifeq ($(BR2_PACKAGE_E2FSPROGS),y)
  23. QUOTA_DEPENDENCIES += host-pkgconf e2fsprogs
  24. QUOTA_CONF_OPTS += --enable-ext2direct
  25. else
  26. QUOTA_CONF_OPTS += --disable-ext2direct
  27. endif
  28. ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
  29. QUOTA_DEPENDENCIES += libtirpc host-pkgconf
  30. endif
  31. ifeq ($(BR2_PACKAGE_OPENLDAP):$(BR2_STATIC_LIBS),y:)
  32. QUOTA_DEPENDENCIES += openldap
  33. QUOTA_CONF_OPTS += --enable-ldapmail
  34. else
  35. QUOTA_CONF_OPTS += --disable-ldapmail
  36. endif
  37. $(eval $(autotools-package))