qt5.mk 992 B

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # qt5
  4. #
  5. ################################################################################
  6. QT5_VERSION_MAJOR = 5.15
  7. QT5_VERSION = $(QT5_VERSION_MAJOR).1
  8. QT5_SOURCE_TARBALL_PREFIX = everywhere-src
  9. QT5_SITE = https://download.qt.io/archive/qt/$(QT5_VERSION_MAJOR)/$(QT5_VERSION)/submodules
  10. include $(sort $(wildcard package/qt5/*/*.mk))
  11. # The file "qt.conf" can be used to override the hard-coded paths that are
  12. # compiled into the Qt library. We need it to make "qmake" relocatable and
  13. # tweak the per-package install pathes
  14. define QT5_INSTALL_QT_CONF
  15. sed -e "s|@@HOST_DIR@@|$(HOST_DIR)|" -e "s|@@STAGING_DIR@@|$(STAGING_DIR)|" \
  16. $(QT5BASE_PKGDIR)/qt.conf.in > $(HOST_DIR)/bin/qt.conf
  17. endef
  18. ifeq ($(BR2_PER_PACKAGE_DIRECTORIES),y)
  19. define QT5_QT_CONF_FIXUP
  20. $(QT5_INSTALL_QT_CONF)
  21. endef
  22. endif
  23. # Variable for other Qt applications to use
  24. QT5_QMAKE = $(HOST_DIR)/bin/qmake -spec devices/linux-buildroot-g++