qlibc.mk 703 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # qlibc
  4. #
  5. ################################################################################
  6. QLIBC_VERSION = 2.4.5
  7. QLIBC_SITE = $(call github,wolkykim,qlibc,v$(QLIBC_VERSION))
  8. QLIBC_LICENSE = BSD-2-Clause
  9. QLIBC_LICENSE_FILES = LICENSE
  10. QLIBC_INSTALL_STAGING = YES
  11. QLIBC_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
  12. # The configure.ac checks for these use AC_CHECK_FILE() which doesn't
  13. # work for cross-compilation. If someone wants to enable the support
  14. # for OpenSSL or MySQL, some changes to the configure.ac will be
  15. # needed.
  16. QLIBC_CONF_OPTS = --without-mysql --without-openssl
  17. $(eval $(autotools-package))