python-gunicorn.mk 1.0 KB

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # python-gunicorn
  4. #
  5. ################################################################################
  6. PYTHON_GUNICORN_VERSION = 19.9.0
  7. PYTHON_GUNICORN_SOURCE = gunicorn-$(PYTHON_GUNICORN_VERSION).tar.gz
  8. PYTHON_GUNICORN_SITE = https://files.pythonhosted.org/packages/47/52/68ba8e5e8ba251e54006a49441f7ccabca83b6bef5aedacb4890596c7911
  9. PYTHON_GUNICORN_SETUP_TYPE = setuptools
  10. PYTHON_GUNICORN_LICENSE = MIT
  11. PYTHON_GUNICORN_LICENSE_FILES = LICENSE
  12. # At the end of the build, we try to compile all py files using the host python
  13. # that has been built.
  14. # The GAIO HTTP Worker is only compatible with Python3.4.2 and up. So don't try
  15. # to compile it with python 2.x
  16. ifeq ($(BR2_PACKAGE_PYTHON),y)
  17. define PYTHON_GUNICORN_REMOVE_GAIO_WORKER
  18. find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/ \
  19. -name "_gaiohttp.py" -exec rm -f {} \;
  20. endef
  21. PYTHON_GUNICORN_POST_INSTALL_TARGET_HOOKS += PYTHON_GUNICORN_REMOVE_GAIO_WORKER
  22. endif
  23. $(eval $(python-package))