pv.mk 1.1 KB

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # pv
  4. #
  5. ################################################################################
  6. PV_VERSION = 1.6.6
  7. PV_SOURCE = pv-$(PV_VERSION).tar.bz2
  8. PV_SITE = http://www.ivarch.com/programs/sources
  9. PV_LICENSE = Artistic-2.0
  10. PV_LICENSE_FILES = doc/COPYING
  11. PV_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
  12. # --relax linker option is enabled by default on sparc/sparc64
  13. # architectures, and it can't be used together with -r option, so
  14. # disable it.
  15. ifeq ($(BR2_sparc)$(BR2_sparc64),y)
  16. PV_LDFLAGS = "-Wl,--no-relax"
  17. endif
  18. # While 'pv' uses autoconf, it does not use automake for its
  19. # makefiles. It uses $(LD) $(LDFLAGS) to achieve partial linking, but
  20. # using 'ld' directly doesn't work well with some toolchain
  21. # configuration, as the ld default emulation may not necessarily be
  22. # the correct one. By passing the below values for LD and LDFLAGS, we
  23. # ensure that 'gcc' is used to do these partial linking steps.
  24. PV_MAKE_OPTS = \
  25. LD="$(TARGET_CC)" \
  26. LDFLAGS="-Wl,-r -nostdlib $(PV_LDFLAGS)"
  27. $(eval $(autotools-package))