protobuf-c.mk 789 B

1234567891011121314151617181920212223
  1. ################################################################################
  2. #
  3. # protobuf-c
  4. #
  5. ################################################################################
  6. PROTOBUF_C_VERSION = 1.3.3
  7. PROTOBUF_C_SITE = $(call github,protobuf-c,protobuf-c,v$(PROTOBUF_C_VERSION))
  8. PROTOBUF_C_DEPENDENCIES = host-protobuf-c
  9. HOST_PROTOBUF_C_DEPENDENCIES = host-protobuf host-pkgconf
  10. PROTOBUF_C_MAKE = $(MAKE1)
  11. PROTOBUF_C_CONF_OPTS = --disable-protoc
  12. PROTOBUF_C_INSTALL_STAGING = YES
  13. PROTOBUF_C_LICENSE = BSD-2-Clause
  14. PROTOBUF_C_LICENSE_FILES = LICENSE
  15. PROTOBUF_C_AUTORECONF = YES
  16. HOST_PROTOBUF_C_AUTORECONF = YES
  17. # host-protobuf needs c++11 (since 3.6.0)
  18. HOST_PROTOBUF_C_CONF_ENV += CXXFLAGS="$(HOST_CXXFLAGS) -std=c++11"
  19. $(eval $(autotools-package))
  20. $(eval $(host-autotools-package))