procps-ng.mk 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. ################################################################################
  2. #
  3. # procps-ng
  4. #
  5. ################################################################################
  6. PROCPS_NG_VERSION = 3.3.15
  7. PROCPS_NG_SOURCE = procps-ng-$(PROCPS_NG_VERSION).tar.xz
  8. PROCPS_NG_SITE = http://downloads.sourceforge.net/project/procps-ng/Production
  9. PROCPS_NG_LICENSE = GPL-2.0+, LGPL-2.0+ (libproc and libps)
  10. PROCPS_NG_LICENSE_FILES = COPYING COPYING.LIB
  11. PROCPS_NG_INSTALL_STAGING = YES
  12. PROCPS_NG_DEPENDENCIES = ncurses host-pkgconf $(TARGET_NLS_DEPENDENCIES)
  13. PROCPS_NG_CONF_OPTS = LIBS=$(TARGET_NLS_LIBS)
  14. ifeq ($(BR2_PACKAGE_SYSTEMD),y)
  15. PROCPS_NG_DEPENDENCIES += systemd
  16. PROCPS_NG_CONF_OPTS += --with-systemd
  17. else
  18. PROCPS_NG_CONF_OPTS += --without-systemd
  19. endif
  20. # Make sure binaries get installed in /bin, as busybox does, so that we
  21. # don't end up with two versions.
  22. # Make sure libprocps.pc is installed in STAGING_DIR/usr/lib/pkgconfig/
  23. # otherwise it's installed in STAGING_DIR/lib/pkgconfig/ breaking
  24. # pkg-config --libs libprocps.
  25. PROCPS_NG_CONF_OPTS += --exec-prefix=/ \
  26. --libdir=/usr/lib
  27. # Allows unicode characters to show in 'watch'
  28. ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
  29. PROCPS_NG_CONF_OPTS += \
  30. --enable-watch8bit
  31. endif
  32. ifeq ($(BR2_USE_WCHAR),)
  33. PROCPS_NG_CONF_OPTS += CPPFLAGS=-DOFF_XTRAWIDE
  34. endif
  35. # numa support requires libdl, so explicitly disable it when
  36. # BR2_STATIC_LIBS=y
  37. ifeq ($(BR2_STATIC_LIBS),y)
  38. PROCPS_NG_CONF_OPTS += --disable-numa
  39. endif
  40. # Avoid installing S02sysctl, since openrc provides /etc/init.d/sysctl.
  41. define PROCPS_NG_INSTALL_INIT_OPENRC
  42. @:
  43. endef
  44. define PROCPS_NG_INSTALL_INIT_SYSV
  45. $(INSTALL) -D -m 755 package/procps-ng/S02sysctl \
  46. $(TARGET_DIR)/etc/init.d/S02sysctl
  47. endef
  48. $(eval $(autotools-package))