powertop.mk 812 B

12345678910111213141516171819202122232425
  1. ################################################################################
  2. #
  3. # powertop
  4. #
  5. ################################################################################
  6. POWERTOP_VERSION = 2.13
  7. POWERTOP_SITE = https://01.org/sites/default/files/downloads
  8. POWERTOP_DEPENDENCIES = pciutils ncurses libnl host-pkgconf \
  9. $(TARGET_NLS_DEPENDENCIES)
  10. POWERTOP_LICENSE = GPL-2.0
  11. POWERTOP_LICENSE_FILES = COPYING
  12. POWERTOP_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
  13. # 0001-dont-force-stack-smashing-protection.patch
  14. POWERTOP_AUTORECONF = YES
  15. # Help powertop at finding the right ncurses library depending on
  16. # which one is available.
  17. ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
  18. POWERTOP_CONF_ENV += ac_cv_search_delwin="-lncursesw"
  19. else
  20. POWERTOP_CONF_ENV += ac_cv_search_delwin="-lncurses"
  21. endif
  22. $(eval $(autotools-package))