pound.mk 624 B

123456789101112131415161718192021222324
  1. ################################################################################
  2. #
  3. # pound
  4. #
  5. ################################################################################
  6. POUND_VERSION = 2.8
  7. POUND_SITE = http://www.apsis.ch/pound
  8. POUND_SOURCE = Pound-$(POUND_VERSION).tgz
  9. POUND_LICENSE = GPL-3.0+
  10. POUND_LICENSE_FILES = GPL.txt
  11. POUND_DEPENDENCIES = openssl host-openssl
  12. # Force owner/group to us, otherwise it will try proxy:proxy by
  13. # default.
  14. POUND_CONF_OPTS = \
  15. --with-owner=$(shell id -un) \
  16. --with-group=$(shell id -gn)
  17. ifeq ($(BR2_PACKAGE_PCRE),y)
  18. POUND_DEPENDENCIES += pcre
  19. endif
  20. $(eval $(autotools-package))