polkit.mk 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. ################################################################################
  2. #
  3. # polkit
  4. #
  5. ################################################################################
  6. POLKIT_VERSION = 0.116
  7. POLKIT_SITE = http://www.freedesktop.org/software/polkit/releases
  8. POLKIT_LICENSE = GPL-2.0
  9. POLKIT_LICENSE_FILES = COPYING
  10. POLKIT_AUTORECONF = YES
  11. POLKIT_INSTALL_STAGING = YES
  12. POLKIT_DEPENDENCIES = \
  13. libglib2 host-intltool expat spidermonkey $(TARGET_NLS_DEPENDENCIES)
  14. # spidermonkey needs C++11
  15. POLKIT_CONF_ENV = \
  16. CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11" \
  17. LIBS=$(TARGET_NLS_LIBS)
  18. POLKIT_CONF_OPTS = \
  19. --with-os-type=unknown \
  20. --disable-man-pages \
  21. --disable-examples \
  22. --disable-libelogind \
  23. --disable-libsystemd-login
  24. ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
  25. POLKIT_CONF_OPTS += --enable-introspection
  26. POLKIT_DEPENDENCIES += gobject-introspection
  27. else
  28. POLKIT_CONF_OPTS += --disable-introspection
  29. endif
  30. ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
  31. POLKIT_DEPENDENCIES += linux-pam
  32. POLKIT_CONF_OPTS += --with-authfw=pam
  33. else
  34. POLKIT_CONF_OPTS += --with-authfw=shadow
  35. endif
  36. define POLKIT_USERS
  37. polkitd -1 polkitd -1 * - - - Polkit Daemon
  38. endef
  39. define POLKIT_PERMISSIONS
  40. /etc/polkit-1 r 750 root polkitd - - - - -
  41. /usr/share/polkit-1 r 750 root polkitd - - - - -
  42. /usr/bin/pkexec f 4755 root root - - - - -
  43. endef
  44. define POLKIT_INSTALL_INIT_SYSTEMD
  45. $(INSTALL) -D -m 644 $(POLKIT_PKGDIR)/polkit.service \
  46. $(TARGET_DIR)/usr/lib/systemd/system/polkit.service
  47. endef
  48. $(eval $(autotools-package))