pixman.mk 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. ################################################################################
  2. #
  3. # pixman
  4. #
  5. ################################################################################
  6. PIXMAN_VERSION = 0.40.0
  7. PIXMAN_SOURCE = pixman-$(PIXMAN_VERSION).tar.xz
  8. PIXMAN_SITE = https://xorg.freedesktop.org/releases/individual/lib
  9. PIXMAN_LICENSE = MIT
  10. PIXMAN_LICENSE_FILES = COPYING
  11. PIXMAN_INSTALL_STAGING = YES
  12. PIXMAN_DEPENDENCIES = host-pkgconf
  13. HOST_PIXMAN_DEPENDENCIES = host-pkgconf
  14. # For 0001-Disable-tests.patch
  15. PIXMAN_AUTORECONF = YES
  16. # don't build gtk based demos
  17. PIXMAN_CONF_OPTS = --disable-gtk
  18. # The ARM SIMD code from pixman requires a recent enough ARM core, but
  19. # there is a runtime CPU check that makes sure it doesn't get used if
  20. # the HW doesn't support it. The only case where the ARM SIMD code
  21. # cannot be *built* at all is when the platform doesn't support ARM
  22. # instructions at all, so we have to disable that explicitly.
  23. ifeq ($(BR2_ARM_CPU_HAS_ARM),y)
  24. PIXMAN_CONF_OPTS += --enable-arm-simd
  25. else
  26. PIXMAN_CONF_OPTS += --disable-arm-simd
  27. endif
  28. ifeq ($(BR2_ARM_CPU_HAS_ARM)$(BR2_ARM_CPU_HAS_NEON),yy)
  29. PIXMAN_CONF_OPTS += --enable-arm-neon
  30. else
  31. PIXMAN_CONF_OPTS += --disable-arm-neon
  32. endif
  33. # disable iwmmxt support for CPU's that don't have
  34. # this feature
  35. ifneq ($(BR2_iwmmxt),y)
  36. PIXMAN_CONF_OPTS += --disable-arm-iwmmxt
  37. endif
  38. # toolchain gets confused about TLS access through GOT (PIC), so disable TLS
  39. # movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
  40. # {standard input}:172: Error: bad expression
  41. ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII),y)
  42. PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
  43. endif
  44. $(eval $(autotools-package))
  45. $(eval $(host-autotools-package))