piglit.mk 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. ################################################################################
  2. #
  3. # piglit
  4. #
  5. ################################################################################
  6. PIGLIT_VERSION = 2affee53f3ad7a96f5b397a2b6d6408af8a374b0
  7. PIGLIT_SITE = https://gitlab.freedesktop.org/mesa/piglit.git
  8. PIGLIT_SITE_METHOD = git
  9. PIGLIT_LICENSE = MIT (code), \
  10. LGPL-2.0+ (tests/glslparsertest/glsl2/gst-gl-*), \
  11. LGPL-2.1+ (some tests), \
  12. GPL-3.0 (tests/glslparsertest/glsl2/norsetto-*), \
  13. GPL-2.0+ (tests/glslparsertest/glsl2/xreal-*, some other shaders), \
  14. BSD-3-Clause (tests/glslparsertest/shaders/*)
  15. PIGLIT_LICENSE_FILES = COPYING licences/GPL-2 licences/GPL-3 licences/LGPL-2
  16. PIGLIT_DEPENDENCIES = host-pkgconf \
  17. host-python-mako \
  18. host-python-numpy \
  19. host-python-six \
  20. libpng \
  21. python-mako \
  22. python-numpy \
  23. python-six \
  24. waffle \
  25. zlib
  26. PIGLIT_CONF_OPTS += \
  27. -DPIGLIT_USE_WAFFLE=ON \
  28. -DPIGLIT_BUILD_CL_TESTS=OFF \
  29. -DPIGLIT_BUILD_WGL_TESTS=OFF \
  30. -DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3
  31. ifeq ($(BR2_PACKAGE_XORG7),y)
  32. # libxcb for xcb-dri2
  33. PIGLIT_DEPENDENCIES += \
  34. xlib_libX11 \
  35. xlib_libXext \
  36. xorgproto \
  37. $(if $(BR2_PACKAGE_LIBXCB),libxcb)
  38. endif
  39. ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
  40. PIGLIT_DEPENDENCIES += libgl libdrm
  41. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GL_TESTS=ON
  42. else
  43. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GL_TESTS=OFF
  44. endif
  45. ifeq ($(BR2_PACKAGE_XORG7)$(BR2_PACKAGE_HAS_LIBGL),yy)
  46. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GLX_TESTS=ON
  47. else
  48. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GLX_TESTS=OFF
  49. endif
  50. ifeq ($(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_HAS_LIBGLES),yy)
  51. PIGLIT_DEPENDENCIES += libegl
  52. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GLES1_TESTS=ON \
  53. -DPIGLIT_BUILD_GLES2_TESTS=ON \
  54. -DPIGLIT_BUILD_GLES3_TESTS=ON
  55. else
  56. PIGLIT_CONF_OPTS += -DPIGLIT_BUILD_GLES1_TESTS=OFF \
  57. -DPIGLIT_BUILD_GLES2_TESTS=OFF \
  58. -DPIGLIT_BUILD_GLES3_TESTS=OFF
  59. endif
  60. ifeq ($(BR2_PACKAGE_WAYLAND),y)
  61. PIGLIT_DEPENDENCIES += wayland libxkbcommon
  62. endif
  63. $(eval $(cmake-package))