picocom.mk 563 B

1234567891011121314151617181920
  1. ################################################################################
  2. #
  3. # picocom
  4. #
  5. ################################################################################
  6. PICOCOM_VERSION = 3.1
  7. PICOCOM_SITE = $(call github,npat-efault,picocom,$(PICOCOM_VERSION))
  8. PICOCOM_LICENSE = GPL-2.0+
  9. PICOCOM_LICENSE_FILES = LICENSE.txt
  10. define PICOCOM_BUILD_CMDS
  11. $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
  12. endef
  13. define PICOCOM_INSTALL_TARGET_CMDS
  14. $(INSTALL) -D -m 0755 $(@D)/picocom $(TARGET_DIR)/usr/bin/picocom
  15. endef
  16. $(eval $(generic-package))