phytool.mk 702 B

123456789101112131415161718192021222324
  1. ################################################################################
  2. #
  3. # phytool
  4. #
  5. ################################################################################
  6. PHYTOOL_VERSION = 2
  7. PHYTOOL_SOURCE = phytool-$(PHYTOOL_VERSION).tar.xz
  8. PHYTOOL_SITE = https://github.com/wkz/phytool/releases/download/v$(PHYTOOL_VERSION)
  9. PHYTOOL_LICENSE = GPL-2.0+
  10. PHYTOOL_LICENSE_FILES = LICENSE
  11. define PHYTOOL_BUILD_CMDS
  12. $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
  13. LDLIBS="$(TARGET_LDFLAGS)"
  14. endef
  15. define PHYTOOL_INSTALL_TARGET_CMDS
  16. $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
  17. DESTDIR="$(TARGET_DIR)" \
  18. PREFIX="usr" install
  19. endef
  20. $(eval $(generic-package))