php-yaml.mk 781 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # php-yaml
  4. #
  5. ################################################################################
  6. PHP_YAML_VERSION = 2.0.4
  7. PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
  8. PHP_YAML_SITE = https://pecl.php.net/get
  9. PHP_YAML_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
  10. --with-yaml=$(STAGING_DIR)/usr
  11. # phpize does the autoconf magic
  12. PHP_YAML_DEPENDENCIES = libyaml php host-autoconf
  13. PHP_YAML_LICENSE = MIT
  14. PHP_YAML_LICENSE_FILES = LICENSE
  15. define PHP_YAML_PHPIZE
  16. (cd $(@D); \
  17. PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
  18. PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
  19. $(STAGING_DIR)/usr/bin/phpize)
  20. endef
  21. PHP_YAML_PRE_CONFIGURE_HOOKS += PHP_YAML_PHPIZE
  22. $(eval $(autotools-package))