php-gnupg.mk 850 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # php-gnupg
  4. #
  5. ################################################################################
  6. PHP_GNUPG_VERSION = 1.4.0
  7. PHP_GNUPG_SOURCE = gnupg-$(PHP_GNUPG_VERSION).tgz
  8. PHP_GNUPG_SITE = https://pecl.php.net/get
  9. # phpize does the autoconf magic
  10. PHP_GNUPG_DEPENDENCIES = php libgpgme host-autoconf host-pkgconf
  11. PHP_GNUPG_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
  12. --with-gnupg=$(STAGING_DIR)/usr/include --with-gpg=/usr/bin/gpg
  13. PHP_GNUPG_LICENSE = BSD-2-Clause
  14. PHP_GNUPG_LICENSE_FILES = LICENSE
  15. define PHP_GNUPG_PHPIZE
  16. (cd $(@D); \
  17. PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
  18. PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
  19. $(STAGING_DIR)/usr/bin/phpize)
  20. endef
  21. PHP_GNUPG_PRE_CONFIGURE_HOOKS += PHP_GNUPG_PHPIZE
  22. $(eval $(autotools-package))