php-geoip.mk 798 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # php-geoip
  4. #
  5. ################################################################################
  6. PHP_GEOIP_VERSION = 1.1.1
  7. PHP_GEOIP_SOURCE = geoip-$(PHP_GEOIP_VERSION).tgz
  8. PHP_GEOIP_SITE = https://pecl.php.net/get
  9. PHP_GEOIP_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
  10. --with-geoip=$(STAGING_DIR)/usr
  11. # phpize does the autoconf magic
  12. PHP_GEOIP_DEPENDENCIES = geoip php host-autoconf
  13. PHP_GEOIP_LICENSE = PHP-3.01
  14. PHP_GEOIP_LICENSE_FILES = geoip.c
  15. define PHP_GEOIP_PHPIZE
  16. (cd $(@D); \
  17. PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
  18. PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
  19. $(STAGING_DIR)/usr/bin/phpize)
  20. endef
  21. PHP_GEOIP_PRE_CONFIGURE_HOOKS += PHP_GEOIP_PHPIZE
  22. $(eval $(autotools-package))