pcre2.mk 908 B

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # pcre2
  4. #
  5. ################################################################################
  6. PCRE2_VERSION = 10.35
  7. PCRE2_SITE = https://ftp.pcre.org/pub/pcre
  8. PCRE2_SOURCE = pcre2-$(PCRE2_VERSION).tar.bz2
  9. PCRE2_LICENSE = BSD-3-Clause
  10. PCRE2_LICENSE_FILES = LICENCE
  11. PCRE2_INSTALL_STAGING = YES
  12. PCRE2_CONFIG_SCRIPTS = pcre2-config
  13. PCRE2_CONF_OPTS += --enable-pcre2-8
  14. PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_16),--enable-pcre2-16,--disable-pcre2-16)
  15. PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_32),--enable-pcre2-32,--disable-pcre2-32)
  16. ifeq ($(BR2_PACKAGE_PCRE2_JIT),y)
  17. PCRE2_CONF_OPTS += --enable-jit
  18. else
  19. PCRE2_CONF_OPTS += --disable-jit
  20. endif
  21. # disable fork usage if not available
  22. ifeq ($(BR2_USE_MMU),)
  23. PCRE2_CONF_OPTS += --disable-pcre2grep-callout
  24. endif
  25. $(eval $(autotools-package))
  26. $(eval $(host-autotools-package))