paxtest.mk 1.0 KB

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # paxtest
  4. #
  5. ################################################################################
  6. PAXTEST_VERSION = 0.9.15
  7. PAXTEST_SITE = https://www.grsecurity.net/~spender
  8. PAXTEST_LICENSE = GPL-2.0+
  9. PAXTEST_LICENSE_FILES = README
  10. define PAXTEST_BUILD_CMDS
  11. $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
  12. RUNDIR="/usr/lib/paxtest" CC="$(TARGET_CC)" LD="$(TARGET_CC)" linux
  13. endef
  14. # The files installed to RUNDIR include test apps and shared libs.
  15. # Assuming /usr/bin/paxtest script solely uses these libs and apps, the
  16. # genpaxtest script updates LD_LIBRARY_PATH in the paxtest script
  17. # as part of the paxtest's creation to include the RUNDIR path for shared
  18. # library use.
  19. define PAXTEST_INSTALL_TARGET_CMDS
  20. $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
  21. CC="$(TARGET_CC)" LD="$(TARGET_CC)" \
  22. DESTDIR=$(TARGET_DIR) \
  23. BINDIR="usr/bin" \
  24. RUNDIR="/usr/lib/paxtest" -f Makefile.psm install
  25. endef
  26. $(eval $(generic-package))